My Arlo Baby is not connected to the Internet and the LED is solid purple; what do I do?

If your Arlo Baby camera’s LED lights solid purple, Arlo Baby is connected to your WiFi network but is not connected to the Internet. When this happens, your Arlo Baby camera might appear offline.

To troubleshoot when Arlo Baby is disconnected from the Internet:

  1. Make sure that your Arlo Baby’s battery is at least 20% charged OR make sure that your Arlo Baby is plugged in.
  2. Make sure that your Arlo Baby is connected to your WiFi network.
    The WiFi network name displays on the Settings page if Arlo Baby is connected. If Arlo Baby is not connected, select Wi-Fi Network from the Settings page and enter the network name and password, then tap or click Continue and follow the on-screen instructions.
  3. Log out of the Arlo app from the Settings > Profile page and then log back in again, or refresh the my.arlo.com web page.
  4. If your Arlo Baby is still offline, make sure that your router is connected to the Internet and that you can access the Internet from other devices on your WiFi network.
    If none of your WiFi devices are connected to the Internet, you might have a problem with your router, your modem, or your Internet service provider. For more information about troubleshooting problems with your home WiFi network, see the documentation for your router or contact your Internet service provider.
  5. If your other devices are connected to the Internet and Arlo Baby is still offline, try power cycling your Arlo Baby camera:
    1. Unplug the USB cable from your Arlo Baby camera. 
    2. Rotate the foot plate and remove the Arlo Baby character’s feet.
    3. Slide the battery switch on the bottom of Arlo Baby to off.
      The battery is turned off when no green is visible near the battery switch.
    4. Wait ten seconds, then slide the battery switch to on.
      Your Arlo Baby camera restarts.
    5. Replace the foot plate and rotate until it clicks into place.
    6. Plug the USB cable back in.
  6. If the Arlo Baby camera LED is still solid amber, wait until the camera finishes restarting and the LED behavior changes to a different pattern.
  7. If your Arlo Baby camera is still offline after the camera restarts, visit Arlo Support to speak with an expert.

For more information about troubleshooting technical problems with Arlo Baby, visit the following knowledge base articles: